Did you know that you can see which of your tenant guests are using hybrid or entra joined devices?
If you have a Entra Log Analytics Workspace setup, you can use this query to find them
SigninLogs| where TimeGenerated > ago(30d)| extend TrustType = tostring(DeviceDetail.trustType)| where CrossTenantAccessType == @"b2bCollaboration"| where AADTenantId != HomeTenantId| where isnotempty(TrustType)| where UserType == "Guest"| project TimeGenerated, UserPrincipalName, AppDisplayName, IPAddress, TrustType, Browser = tostring(DeviceDetail.browser), ConditionalAccessStatus, ResultType, ResultDescription| order by TimeGenerated desc
Screenshot

This is probably the shortest blog post Ive ever made.
Leave a comment